WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Google Publisher Plugin (beta)

The official Google Publisher Plugin for AdSense, written by Google. Supported products include AdSense and Webmaster Tools.

Also see the AdSense help documentation on installing the Google Publisher Plugin.

After installation, you can set up the plugin.

Make sure you meet the minimum system requirements.

  • PHP version 5.2.0 or greater.
  • WordPress version 3.5 or greater.
  • Ability to install third-party WordPress plugins.
  • Site hosted outside WordPress.com. WordPress.com does not allow this plugin on its hosted sites.

Sign in to your WordPress account and visit the site admin page. You can quickly view this page if you click the WordPress icon in the upper left corner of your WordPress site. Note that you must have permission as an admin of your site to install plugins. If you need help, try WordPress support.

In the site admin sidebar, click Plugins and select Add New. Enter “Google Publisher Plugin” in the search bar and click Search Plugins.

Find the Google Publisher Plugin in the list of results and click the Install Now link.

At this point, WordPress should automatically install the plugin.

If you have any trouble with automatic installation, you can try it manually. To do this:

  • Visit the WordPress plugin directory page for the Google Publisher Plugin. If you don't see the plugin page, enter "Google Publisher Plugin" in the Search Plugins box on the left and click Search.
  • Download the plugin. It should come in the form of a .zip file.
  • Sign in to your WordPress account and visit the site admin page.
  • In the site admin sidebar, click Plugins and select Add New.
  • Select Upload near the top of the plugins page. Click Choose file and upload your .zip file. Then click Install Now.

Move on to plugin setup.

Requires: 3.5 or higher
Compatible up to: 3.9.2
Last Updated: 2014-8-19
Downloads: 86,062

Ratings

3 stars
3.7 out of 5 stars

Support

1 of 13 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

4 people say it works.
0 people say it's broken.

100,1,1
100,1,1
0,4,0
20,5,1
20,5,1
20,5,1
46,28,13
35,23,8
0,1,0
71,7,5
100,4,4