WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Google Maps v3 Shortcode multiple Markers

This plugin supports multiple markers per map! Kudos to yohman for his plugin: http://wordpress.org/extend/plugins/google-maps-v3-shortcode/

How do I add a map to my post?

Use shortcode:

e.g.: [MultipleMarkerMap id="MultipleMarkerMapDemo" z="12" lat="48.220162" lon="16.287525" marker="48.193054,16.261282,Bar,http://google-maps-icons.googlecode.com/files/cocktail.png|48.220162,16.287525,point-of-view,http://google-maps-icons.googlecode.com/files/beautiful.png" w="690" h="442"]

Can I add multiple maps to the same post?

Yes! But make sure you use the "id" parameter to create unique id's for each map.

e.g.: [MultipleMarkerMap id="MultipleMarkerMapDemo" z="12" lat="48.220162" lon="16.287525" marker="48.193054,16.261282,Bar,http://google-maps-icons.googlecode.com/files/cocktail.png|48.220162,16.287525,point-of-view,http://google-maps-icons.googlecode.com/files/beautiful.png" w="690" h="442"]

[MultipleMarkerMap id="MultipleMarkerMapDemo2" z="12" lat="48.220162" lon="16.287525" marker="48.203054,16.261282,Bar,http://google-maps-icons.googlecode.com/files/cocktail.png|48.230162,16.287525,point-of-view,http://google-maps-icons.googlecode.com/files/beautiful.png" w="690" h="442"]

Can I add multiple markers on the same map?

Yes ! Just add following shortcode to your page or post (markers are separated with "|" )

[MultipleMarkerMap id="MultipleMarkerMapDemo" z="12" lat="48.220162" lon="16.287525" marker="48.193054,16.261282,Bar,http://google-maps-icons.googlecode.com/files/cocktail.png|48.220162,16.287525,point-of-view,http://google-maps-icons.googlecode.com/files/beautiful.png" w="690" h="442"]

Can I change the size of the map?

Yes! Just add your own width and height parameters (the default is 400x300).

Ex: [MultipleMarkerMap w="200" h="100"]

Requires: 2.8 or higher
Compatible up to: 3.1.4
Last Updated: 2011-10-7
Downloads: 7,054

Ratings

3 stars
3.6 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
100,1,1
100,1,1
0,1,0