WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Google Authenticator - Per User Prompt

Modifies the Google Authenticator plugin so that only users with 2FA enabled are prompted for the authentication token.

The Google Authenticator plugin is a great way to add two-factor authentication to your site, but it does have one major drawback: it asks every user for the authentication token, regardless of whether they have 2FA enabled or not. This can be confusing for users, which prevents some administrators from using the plugin on multi-user sites.

This plugin modifies the way that Google Authenticator behaves so that only users who have it enabled are prompted for the token. If a user doesn't have it enabled, then they'll proceed directly to the Administration Panels; if they do have it enabled then they'll be prompted to enter their 2FA code.

Requires: 3.5 or higher
Compatible up to: 3.9.1
Last Updated: 2014-6-22
Downloads: 732

Ratings

5 stars
5 out of 5 stars

Support

1 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
0,1,0