WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Google Analyticator

Adds the necessary JavaScript code to enable Google Analytics. Includes widgets for Analytics data display.

Google Analyticator is back! Google Analyticator adds the necessary JavaScript code to enable Google Analytics logging on any WordPress blog. This eliminates the need to edit your template code to begin logging. Google Analyticator also includes several widgets for displaying Analytics data in the admin and on your blog.

For a video explaining the simple installation process, please visit the new home of Google Analyticator.

Features

Google Analyticator Has the Following Features:

  • Supports Universal (analytics.js) and traditional analytics (ga.js)
  • Includes an admin dashboard widget that displays a graph of the last 30 days of visitors, a summary of site usage, the top pages, the top referrers, and the top searches
  • Includes a widget that can be used to display visitor stat information on the front-end
  • Supports outbound link tracking of all links on the page, including links not managed by WordPress
  • Supports download link tracking
  • Supports event tracking with outbound links / downloads instead of the old pageview tracking method
  • Support site speed tracking
  • Allows hiding of Administrator visits without affecting Google Analytics' site overlay feature
  • Supports any advanced tracking code Google provides
  • Installs easily - unlike other plugins, the user doesn't even have to know their Analytics UID
  • Provides complete control over options; disable any feature if needed
  • Supports localization - get the settings page in your language of choice
  • Ability to hide Google UID dropdown
  • Added Polish Translation

For more information, visit the Google Analyticator plugin page.

If you have a great idea on how to improve the plugin, we would love to hear from you at the Google Analyticator Feature Request page

A big thank you from the whole community to Ronald for all the hard work he put into this plugin.

Requires: 3.2 or higher
Compatible up to: 3.8.3
Last Updated: 2014-1-10
Downloads: 3,235,417

Ratings

3 stars
3.7 out of 5 stars

Support

1 of 18 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

2 people say it works.
1 person says it's broken.

100,1,1 100,1,1
100,1,1 100,1,1 100,1,1
100,10,10 100,1,1 100,1,1
100,1,1 100,2,2 100,6,6 100,2,2 100,6,6 100,5,5 100,1,1
100,3,3 58,12,7 100,1,1
74,19,14 100,1,1
80,20,16 88,24,21 91,11,10 0,1,0
96,27,26
97,29,28
0,1,0
100,2,2
100,3,3
86,7,6
55,11,6 69,16,11 100,1,1
100,1,1 100,5,5
100,10,10
100,5,5
50,2,1 100,1,1 0,1,0
100,1,1 100,4,4
86,29,25
100,6,6
95,20,19
80,15,12 100,1,1
60,5,3
12,26,3 100,1,1 100,2,2 100,1,1 100,2,2 100,1,1
0,3,0 0,1,0 80,5,4 67,9,6 22,9,2 59,32,19 100,4,4 100,1,1 100,2,2 100,1,1
89,9,8 100,2,2 100,1,1
100,2,2 9,11,1 100,14,14 100,1,1 100,1,1 75,4,3 80,5,4
50,2,1 0,1,0
100,8,8
60,5,3
100,1,1
80,5,4
100,1,1 100,1,1 100,1,1 50,6,3 100,1,1 100,2,2
70,10,7
100,1,1
25,4,1
100,4,4
67,3,2