WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Global Post Password

Globally set a password for all password protected posts and pages.

1.5

  • WordPress 3.4 and 3.5 compatibility.
  • WordPress 3.4 or later is now a requirement.

1.4.2

  • Add a body class of 'has-post-password' to individual posts when a user has entered the correct password.

1.4.1

  • Additional protection so you can't accidentally remove password protection from all your posts.

1.4

  • Full compatibility with Quick Edit.
  • New settings that enable using post passwords in permalinks and feed URLs.
  • WordPress 2.8 or later is now a requirement.

1.3

  • Introduction of (optional) multiple global passwords.
  • Removal of redundant radio buttons on post editing screen.
  • Support for Quick Edit.
  • WordPress 2.7 or later is now a requirement.

1.2

  • WordPress 2.7 compatibility.

1.1

  • WordPress 2.6 compatibility.

1.0

  • Initial release.

Requires: 3.4 or higher
Compatible up to: 3.5.2
Last Updated: 2012-11-2
Downloads: 14,895

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
0,2,0
0,1,0 100,1,1