WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Genesis Featured Widget Amplified

Genesis Featured Posts with support for custom post types, taxonomies, and so much more

Requires: 3.3 or higher
Compatible up to: 3.3.2
Last Updated: 2012-5-14
Downloads: 39,886

Ratings

4 stars
4.7 out of 5 stars

Support

0 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
1 person says it's broken.

100,2,2 100,1,1 100,1,1
100,1,1
100,1,1 100,2,2 50,2,1 100,2,2
100,1,1
50,2,1
100,2,2
100,1,1 75,4,3 100,1,1 100,2,2 100,1,1
0,1,0 100,3,3
75,4,3
100,5,5
67,6,4
50,4,2
40,5,2
67,3,2
0,1,0
50,2,1
50,2,1
0,1,0