WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

fdsPhotoFEED v1.0.0

A WordPress plugin for grabbing images and image info from SmugMug, Flickr, Picasa etc RSS feeds.

The fdsPhotoFEED plugin uses the lastRSS class to grab images from a SmugMug, Flickr, Picasa etc RSS feed to display on any wordpress hosted website. It provides access to the images title, description, SmugMug, Flickr, Picasa etc page URL, and the image in any size that SmugMug, Flickr, Picasa etc offers.

USAGE: you can do it from any of your post or page. you can set any RSS feed like SmugMug, Picasa, Flickr etc with a limit of how many photos you want in your post/page. You need to keep in mind that you need to assign to things there:

   1. rss uri = feed location
   2. limit = number of photos to be shown

the plugin will replace only the text within the post/page which is encoded with a curly brace {} with resulted photos. The remaindered text will be same. Add your RSS Feed in the body of your post or page in the following format

{rss uri=http://seismictalk.smugmug.com/hack/feed.mg?Type=nicknameRecentPhotos&Da ta=SeismicTalk&format=rss200 limit=5}

Alternatively you can leave the limit blank like this to get all the photos {rss uri=flickr/picasa/smugmug_rss_feed_location limit=}

  1. Plublish your post/page.

[ Note: You may set a limit or leave it blank to retreive all photos ]

FEATURES:

  • It can fetch photos from SmugMug
  • It can fetch photos from Flickr
  • It can fetch photos from Picasa & any other RSS feed
  • It supports image caching
  • It supports lightbox2 slideshow with navigation button Prev & Next
  • Image Caption is fetched and shown in lightbox2 show

REQUIREMENTS:

  • wp-lightbox2 plugin for lightbox2 show. You may get it from HERE

COURTESY:

Thanks goes to Brian Brigg, Hasin Hayder and Lenin for their endless support.

Requires: 2.0.2 or higher
Compatible up to: 2.6.3
Last Updated: 2008-11-10
Downloads: 1,382

Ratings

3 stars
3 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0