WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Extended Super Admins

This plugin allows you to create multiple levels of Super Admins in a multi-site configuration.

0.7

  • Added multi-network support for Networks+ plugin
  • Wrote custom function to switch networks in a multi-network setup
  • Optimized the way Codex information is retrieved, stored and displayed
  • Further optimized JavaScript
  • Minified JavaScript and CSS files used in the plugin (non-minified source files are still included in the package)
  • Added ability to manually flush the Codex information
  • Extended length of Codex cache from 7 days to 30 days
  • Minor change in CSS for 3.2
  • Removed "Activate" and "Deactivate" links from plugins screen if user doesn't have the manage_esa_options capability
  • Cleaned up improper uses of WPDB::prepare()
  • Cleaned up messy SQL calls
  • Removed useless ESA Manager role

0.6.1

  • Hopefully fixed issue that allowed modified users to edit their own permissions
  • Removed alpha indication from plugin version name

0.6a

  • The JavaScript for this plugin has been optimized quite a bit
  • The admin options page now utilizes the standard WordPress meta box interface rather than using a custom interface (thanks to RavanH for the suggestion)
  • Updated the way the Codex dialogs are displayed on-screen

0.5a

  • Fixed bugs that caused roles not to be deleted properly if they had been added without all criteria specified

0.4a

  • Plugin now retrieves information about each capability (where available) from the WordPress Codex
  • In addition to John James Jacoby's WP Multi Network plugin, this plugin should now be compatible with David Dean's Networks for WordPress plugin.
  • Fixed bugs that caused roles not to be deleted properly
  • Made minor UI changes to make it more obvious how roles are added and modified
  • Added a notice warning users when a role is added without a name
  • Special thanks to RavanH for help testing and debugging this version

0.3a

The "stable" copy of 0.2a was missing all subfolders. Corrected this issue.

0.2a

Corrected a version inconsistency between the readme file and the main plugin file. No substantial changes were made to the functionality of this plugin.

0.1

This is the first version.

Requires: 3.0 or higher
Compatible up to: 3.6.1
Last Updated: 2013-9-3
Downloads: 7,638

Ratings

4 stars
4.4 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 67,3,2
100,1,1
50,2,1
100,2,2
0,1,0
100,1,1