WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

EventPress

Create Events on WordPress and BuddyPress!

Why?

Because.

Subscribers can't create events.

If you want the capabilities for users to create events, upgrade them to event creators from the WordPress dashboard.

Requires: WordPress 3.1, BuddyPress 1.2.8 or higher
Compatible up to: 3.1.4
Last Updated: 2011-5-24
Downloads: 17,019

Ratings

3 stars
3.8 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2 100,4,4 100,3,3 75,4,3 100,3,3
100,1,1
50,2,1 100,1,1
100,1,1
50,2,1
100,1,1
100,2,2
0,1,0
0,1,0