WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Embed iPhone/iPad App

a plugin converts iTunes Store URLs into iOS(iPhone/iPad/iPod) app info

Where can I go to join PHG Network?

I want it shown in my language. What can I do?

If you want to add your language translation, what you need to do is add and edit new resource files on your local and check if it translates properly.

The translation resource files are .po and .mo files under languages/ sub-folder. For example, if want to make Italian,

language/embed_iphoneipad_app-it.po language/embed_iphoneipad_app-it.mo

are needed. You may copy the current Japanese .po, rename 'ja' with 'it', and edit .po file with appropriate translation tool such like PoEdit. PoEdit will create .mo from .po automatically when you save.

If you send me those po/mo files, I will include them and the plugin's output will be displayed in that language, when the WordPress's locale is set to the language.

Some app info are not displayed in my locale

The plugin looks up the WordPress locale setting (by get_locale()). If you see info in other language you expect, you need to set locale correctly.

Also, if iTunes App Store does not have the app in the language/country, no info in the language/country are provided so it falls back into the global info(usually English, unless no English support exists).

Apps supported languages are not shown fully but in 2 letter digit(e.g. EN, JA)

If you want it with longer language names in your language, you need PHP Intl extension. If Intl extension is on, languages will be displayed in long text in your locale.

Apps price are not displayed in my locale

If you want prices shown in your locale, you need PHP Intl extension. If Intl extension is on, price will be displayed in your locale's format.

I do not like the current design

Please edit css/embed-iphoneipad-app.css at now. Please keep in mind the plugin-updates may erase your modifications. If you design a better one please send it to us, we may make your style as default.

Requires: 3.3.0 or higher
Compatible up to: 3.6.1
Last Updated: 2013-9-28
Downloads: 3,149

Ratings

4 stars
4 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,2,2
0,1,0
100,1,1 100,1,1