WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Easy Video Player

Easy Video Player allows you to embed videos into your WordPress site.

Easy Video Player is a user-friendly WordPress plugin to showcase your videos. You can embed both self-hosted videos or videos that are external hosted using direct links.

Easy Video Player Features

  • Embed MP4 videos into your blog.
  • Embed responsive videos for a better user experience while viewing from a mobile device.
  • Embed HTML5 videos which are compatible with all major browsers.

Easy Video Player Plugin Usage

Settings Configuration

It's pretty easy to set up this plugin. Once you have installed the plugin simply navigate to the Settings menu where you will be able to configure some options. Mostly you just to need check the "Enable jQuery" option. That will allow the plugin to make use of jQuery library.

Embedding Shortcodes for the Videos

Now it's time to finally embed a video shortcode. To do this create a new post/page and use the following shortcode:

[evp_embed_video url="http://example.com/wp-content/uploads/videos/myvid.mp4"]

here, url is a shortcode parameter that you need to replace the actual URL of the video file.

Video Autoplay

If you want a particular video to start playing when the page loads you can set the "autoplay" option to "true":

[evp_embed_video url="http://example.com/wp-content/uploads/videos/myvid.mp4" autoplay="true"]

Control Size

Many users don't care if the videos are not responsive, and therefore want to control the player size. You can easily do so by specifying a width and height for your video:

[evp_embed_video url="http://example.com/wp-content/uploads/videos/myvid.mp4" width="500" height="400"]

Control Player Ratio

The player ratio is set to "0.417" by default. But you can override it by specifying a different ratio in the shortcode:

[evp_embed_video url="http://example.com/wp-content/uploads/videos/myvid.mp4" ratio="0.345"]

For detailed documentation please visit the Easy Video Player plugin page

Requires: 3.0.1 or higher
Compatible up to: 3.9.1
Last Updated: 2014-6-15
Downloads: 32,645

Ratings

3 stars
3.8 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
1 person says it's broken.

100,1,1
50,2,1
100,1,1
0,1,0