WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Easy Translator

Easy Translator is a machine translator for blog posts and a plugin translation tool for developers and translators.

  • V4.03: Compatibility with WordPress V3.9. [Apr 18, 2014]
  • V4.02: Further minor fixes to suppress PHP notices. [Mar 29, 2014]
  • V4.01: Bug fix in the widget javascript code. [Mar 29, 2014]
  • V4.00: Major overhauling of the design. [Mar 29, 2014]
  • V3.31: Minor refactoring changes. [Mar 24, 2014]
  • V3.30: Compatibility with WP3.8. Documentation changes. [Dec 19, 2013]
  • V3.20: Compatibility with WP3.7. Some minor documentation changes. [Nov 9, 2013]
  • V3.10: Compatibility with WP3.6. Some additional tooltips to help the user. [Aug 15, 2013]
  • V3.01: Documentation changes only. [May 21, 2013]
  • V3.00: Major upgrade with blog page translation as well as Google translate to seed plugin translation. [May 20, 2013]
  • V2.13: Proper session initialization. [Mar 30, 2013]
  • V2.12: Proper use of SESSION variables. [Feb 18, 2013]
  • V2.11: Bug fixes (Fatal error: Call-time pass-by-reference has been removed). [Jan 27, 2013]
  • V2.10: Including a support link on the admin page. [Sep 30, 2012]
  • V2.06: Taking care of some debug notices from WordPress debug mode. [Aug 28, 2012]
  • V2.05: Minor changes to the admin page. [July 18, 2012]
  • V2.04: Taking care of magic_quotes_gpc in PHP. [May 18, 2012]
  • V2.03: Renaming the plugin to drop the word Lite. [May 11, 2012]
  • V2.02: Changing the php file search to recursive. [Mar 20, 2012]
  • V2.01: Adding a new feature to create a new MO file (rather than just editing an existing one). [Mar 19, 2012]
  • V2.00: Releasing a Lite and Pro version. [Mar 6, 2012]
  • V1.01: Correcting a few minor bugs (a) Author email (of the plugin being translated was set to the author of this plugin. (b) The name of the plugin was set to Easy AdSense (Thanks, Sub!). (c) Some corrections are needed for escaping quotation marks and line breaks in locales other than English. Will include them in the next release. (Hard to test because my locale is en_US).
  • V1.00: Initial release. [July 21, 2009]

Requires: 2.8 or higher
Compatible up to: 3.9
Last Updated: 2014-4-18
Downloads: 26,587

Ratings

5 stars
5 out of 5 stars

Support

1 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,1,1
100,1,1
100,1,1
0,1,0 0,1,0
100,1,1
100,1,1
100,1,1 100,1,1