WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Easy Captcha

Several types of captcha to protect your site in one easy to use plugin.

Requires: 3.4 or higher
Compatible up to: 3.5.2
Last Updated: 2013-5-31
Downloads: 21,934

Ratings

4 stars
4.4 out of 5 stars

Support

0 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
1 person says it's broken.

100,2,2
100,3,3
0,1,0
0,1,0
0,1,0