WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Easy Ads

Easy Ads displays AdSense and its alternatives on your blog pages and sidebar widgets: Chitika, BidVertiser, Clicksor etc. Simple yet flexible.

Easy Ads provides a unified and intuitive interface to manage multiple ad providers on your blog. Currently supported are Chitika, BidVertiser, Clicksor, and, of course, AdSense. The list of ad providers will be expanded later on at your request.

AdSense dumped you? Don't be heartbroken; there are other fish in the sea. You may find happiness with BidVertiser, Chitika or Clicksor. Use Easy Ads, and you may get lucky!

Note that this plugin requires PHPv5.0+. If it does not work on your web host, please consider Easy AdSense or Easy AdSense Pro.

Features

  1. Tabbed and intuitive interface for multiple ad providers (AdSense, Chitika etc.).
  2. Rich display and alignment options.
  3. Robust codebase for extending to more ad providers.
  4. Control over the positioning and display of ad blocks in each post or page.
  5. Simple configuration interface -- nothing more than entering your provider id for AdSense or Chitika, and with sensible defaults for the few options present, all with clear instructions.
  6. Specialized widgets for AdSense and Chitika, and common widget interface for the rest.
  7. Available in your own language using machine translation curtsey of Google and Microsoft.

If you want to use only AdSense, you would want to consider my full-fledged, feature-rich plugin Easy AdSense.

Pro Version

Easy Ads is the freely distributed version of a premium plugin. The Pro version gives you even more features.

  1. In the Pro version you have an Admin (Control Panel) tab with:
    • Option to selectively activate or deactivate various ad providers in the Admin Tab, so that you can have only AdSense, or only Chitika, if you so choose.
    • More information about ad positions and slots (as an image in the Admin Tab).
    • Option to set number of ad slots per position.
    • New commands (in the Admin Tab) to Reset All Options, Drop All Options or Migrate Options to a new plugin version.
  2. A filter to ensure that your ads show only on those pages that seem to comply with Google AdSense (and other common provider) policies, which can be important since some comments may render your pages inconsistent with those policies.
  3. It also lets you specify a list of computers where your ads will not be shown, in order to prevent accidental clicks on your own ads -- one of the main reasons AdSense bans you.
  4. Also in the works for the Pro version is a compatibility mode, which solves the issue of the ad insertion messing up your page appearances when using some themes.

The Pro version costs $8.95 and can be purchased online with instant download link.

Future Plans

I would like to hear from you if you have any feature requests or comments.

  1. Ad Rotation: I will provide means to rotate ads among various providers with user-defined frequency.
  2. More Providers: This plugin is designed with extensibility in mind. I will keep adding more ad providers, or even let the end-users add them.
  3. Expertise Level: I plan to introduce expertise levels (Easy, Advanced and Expert tabs) within the tab for each ad provider.
  4. Max Number of Ad blocks: Since some providers require you to limit the number of ad blocks to some policy-driven ceiling, I will expose that option to you. Also to be customized is the number of ads per slot. In this initial release, there are three slots (top, middle and bottom), each of which can take two ad blocks. In a future release, you will have much more customization options.
  5. Internationalization: Future versions will provide MO/PO files for internationalization.
  6. Documentation: As this plugin may have an overwhelming set of options and features, I will try to write a comprehensive help system for it.

Requires: 2.8 or higher
Compatible up to: 3.9.2
Last Updated: 2014-7-17
Downloads: 35,780

Ratings

3 stars
3.6 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

50,2,1 100,1,1 100,1,1 100,1,1
0,2,0 100,1,1
100,1,1 100,2,2 100,1,1