WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Duo Two-Factor Authentication

Easily add Duo Security two-factor authentication to your WordPress website. Enable two-factor authentication for your admins and/or users.

Watch our demo to see how easy it is to add Duo's two-factor authentication to your WordPress blog.

Duo Security provides two-factor authentication as a service to protect against account takeover and data theft. Using the Duo plugin you can easily add Duo two-factor authentication to your WordPress website in just a few minutes!

Rather than relying on a password alone, which can be phished or guessed, Duo's authentication service adds a second layer of security to your WordPress accounts. Duo enables your admins or users to verify their identities using something they have—like their mobile phone or a hardware token—which provides strong authentication and dramatically enhances account security.

Duo is easy to setup and use. With Duo there’s no extra hardware or complicated software to install, just install this plugin and sign up for Duo’s service. Then you can set which user roles you want to enable two-factor authentication for—admins, editors, authors, contributors, and/or subscribers—without setting up user accounts, directory synchronization, servers, or hardware.

When they log in, your users have multiple ways they can authenticate, including:

  • One-tap authentication using Duo’s mobile app (our fastest, easiest way to authenticate)
  • One-time passcodes generated by Duo’s mobile app (works even with no cell coverage)
  • One-time passcodes delivered to any SMS-enabled phone (works even with no cell coverage)
  • Phone callback to any phone (mobile or landline!)
  • One-time passcodes generated by an OATH-compliant hardware token (if you’re feeling all old school)

Protect your WordPress website in minutes with Duo.

Requires: 3.0 or higher
Compatible up to: 3.9.1
Last Updated: 2014-5-2
Downloads: 16,322

Ratings

4 stars
4.2 out of 5 stars

Support

3 of 3 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
1 person says it's broken.

100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1
100,1,1 100,2,2 100,1,1 100,2,2 100,1,1 100,2,2
100,1,1 100,1,1 100,1,1
100,2,2 100,2,2
100,1,1 100,1,1
100,1,1
50,2,1
100,2,2
50,2,1
100,1,1 100,1,1
100,1,1
100,2,2
100,1,1
100,1,1
100,2,2 100,1,1
100,1,1
33,3,1 100,1,1 100,1,1
0,1,0
0,1,0