WordPress.org

Ready to get started?Download WordPress

Plugin Directory

dlb's Send-A-Link

dlb's Send-A-Link allows visitors to send someone an email containing a link to the post or page.

How can I change the wording and styles in the email message and on the *Send-A-Link* pages?

Most of the visible elements are defined in the template and CSS files. You can make your modifications to a copy of them stored in your theme folder so that they are retained when you upgrade to a new version of Send-A-Link.

What are the template and style file names?

The input form template is dsl-page.html. The confirmation page and email message templates are in file dsl-templates.html. The CSS styles are in file dsl.css.

Can I change the icon and text in the link?

Yes. The parameters for shortcode [dsl-link] and function dslLink() are as follows: show can be "icon", "text", or "both" to display only the icon, only the text or both; iconfile is the name of your icon file, with a path relative to the plugin folder; text is shown as a tooltip and on the link if show is either "text" or "both". In the shortcode, enter them like this: [dsl-link show="both" text="Your Text" iconfile="myIcon.gif" ]. In the function, enter them like this: dslLink( array( "show" => "both" , "text" => "Your Text" , "iconfile" => "myIcon.gif" ) ).

How can I change to wording on the form's submit button?

This can only be changed in file dsl.php. Search for the definition of DSL_SUBMIT_BUTTON_VALUE. This change will need to be made again after an upgrade to a new version.

How can I change the maximum number of characters allowed in names and comments?

This can only be changed in file dsl.php. Search for the definitions of DSL_MAX_COMMENT_CHARS, DSL_MAX_NAME_CHARS, and DSL_MIN_NAME_CHARS. These changes will need to be made again after an upgrade to a new version.

How can I change the minimum time between sends?

This can only be changed in file dsl.php. Search for the definition of DSL_MIN_SEND_INTERVAL. This change will need to be made again after an upgrade to a new version.

How can I change the wording in the error messages?

In this version of the plugin, the error messages must be changed by editing file dsl.php, which is heavily commented to make it easier to navigate and alter the code. A future release will make this easier by using the WordPress localization system. These changes will need to be made again after an upgrade to a new version.

Requires: 3.5.1 or higher
Compatible up to: 3.5.2
Last Updated: 2013-6-19
Downloads: 620

Ratings

0 stars
0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.