WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Disable Directory Listings

Version: 2.0 Prevent virtual directory listing services from listing the contents of directories, and/or show a page in place of a directory's l

2.0

  • Use plugin framework v026, which among other things adds support for:
    • Reset of options to default values
    • Better sanitization of input values
    • Offload core/basic functionality to generic plugin framework
    • Additional hooks for various stages/places of plugin operation
    • Easier localization support
  • Full localization support
  • Update can_write_htaccess() to recognize (but not support) IIS7
  • Add admin notice after plugin activation to warn user that rewrite rules need to be regenerated if their .htaccess isn't writable
  • Add __construct(), activation(), uninstall(), load_config(), register_filters(), install(), maybe_regenerate_rewrite_rules(), display_activation_notice(), options_page_description()
  • Rename deinstall() to deactivate()
  • Change handling of activation and deactivation
  • Save a static version of itself in class variable $instance
  • Deprecate use of global variable $disable_directory_listings to store instance
  • Rename class from 'DisableDirectoryListings' to 'c2c_DisableDirectoryListings'
  • Remove docs from top of plugin file (all that and more are in readme.txt)
  • Note compatibility with WP 3.0+ through WP 3.2+
  • Drop compatibility with versions of WP older than 3.0
  • Explicitly declare all class functions public
  • Add PHPDoc documentation
  • Add package info to top of plugin file
  • Add 'Text Domain' header tag
  • Improve documentation
  • Change description
  • Add Changelog and Upgrade Notice sections to readme.txt
  • Add screenshot
  • Update copyright date (2011)
  • Add .pot file

1.0

  • Initial release

Requires: 3.0 or higher
Compatible up to: 3.2.1
Last Updated: 2011-7-29
Downloads: 3,385

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
0,1,0