WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Development Theme Test

Trying to edit your theme or test a new theme can be very difficult without a testing server or a dev location. Dev Theme Test allows you to create a

Development and staging environments are crucial for website development. It is very poor practice to make direct edits to the live site. WordPress does a good job about allowing an author to develop pages and preview and edit them without publishing them but there is a lack of tools when it comes to theme development. This plugin is meant to bridge the gap when it comes to developing themes without disrupting the experience for the users.

Other uses can include creating a subdomain for different users such as mobile susers. You can create a mobile subdomain with a mobile theme and send your visitors there!

Installation – Our plugin is designed to be easy to install. Feel free to use our installation page for instructions on how to install the plugin. Getting Started – Our Getting Started page is designed to be a brief tutorial on how to use the plugin.

Subdomains – Using subdomains you can create a way to view your site differently. This can be used in development of a new theme, editing of a current theme, or providing a different theme for different users like mobile users!

Development Mode – You are able to set up a template in development mode which creates a copy of the current theme and allows you to edit the dev template while leaving the original theme untouched. It also gives you a simple “Commit” button that will copy over all the newer files from the dev theme and replaces the older ones in the original theme.

Members Only – Setting your subdomain as “Users Only” will require a valid login to access that subdomain.

FAQs – If you have any questions you may find the answers to them in our FAQ section.

Comments/Questions – If you are unable to get the help you need from the FAQ page or you have a suggestion on ways we can improve our plugin we offer you a form where you can submit them to us.

Requires: 2.1.2 or higher
Compatible up to: 2.9.2
Last Updated: 2010-5-7
Downloads: 3,054

Ratings

3 stars
3.2 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
0,1,0
100,1,1
50,2,1
0,2,0
0,1,0