WordPress.org

Ready to get started?Download WordPress

Plugin Directory

CPT Bootstrap Carousel

A custom post type for choosing images and content which outputs Bootstrap Image Carousel (slider) from the [image-carousel] shortcode.

A custom post type for choosing images and content which outputs a carousel from Twitter Bootstrap using the shortcode [image-carousel].

The plugin assumes that you're already using Bootstrap, so you need to load the Bootstrap javascript and CSS separately.

If you'd like to contribute to this plugin, you can find it hosted on GitHub.

Shortcode Options

As of version 1.5, nearly all of these options can be set in the CPT Bootstrap Carousel Settings page. However, if you'd like different settings for different carousels, you can override these by using shortcode options...

  • interval (default 5000)
    • Length of time for the caption to pause on each image. Time in milliseconds.
[image-carousel interval="12000"]
  • showcaption (default true)
    • Whether to display the text caption on each image or not. true or false.
[image-carousel showcaption="false"]
  • showcontrols (default true)
    • Whether to display the control arrows or not. true or false.
[image-carousel showcontrols="false"]
  • orderby and order (default menu_order ASC)
[image-carousel orderby="rand"]
[image-carousel orderby="date" orderby="DESC"]
  • category (default all)
    • Filter carousel items by a comma separated list of carousel category slugs.
[image-carousel category="homepage,highlights"]
  • id (default all)
    • Specify the ID of a specific carousel post to display only one image.
    • Find the image ID by looking at the edit post link, eg. post 109 would be /wp-admin/post.php?post=109&action=edit
[image-carousel id="109"]
  • twbs (default 2)
    • Output markup for Twitter Bootstrap Version 2 or 3.
[image-carousel twbs="3"]

Credits

This plugin was written by @tallphil with help and suggestions from several others including (but not limited to) @joshgerdes, @atnon and @grahamharper.

Requires: 3.0.1 or higher
Compatible up to: 3.8.3
Last Updated: 2014-8-4
Downloads: 25,697

Ratings

4 stars
4.4 out of 5 stars

Support

6 of 6 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
100,1,1
100,1,1
100,1,1 100,1,1
100,1,1
100,1,1 100,1,1
100,3,3 100,1,1
100,2,2