WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

COP CSS Custom Post Type Lite

Adds a custom post type for implementing theme independent css.

Adds a custom post type of css that will compile all entries into a single minified css file that will automatically be enqueued to your site.

Minified CSS is stored in a transient for caching.

User now needs 'edit_themes' permission to see the css editor. By default this is only the administrator.

Shortcodes

Shortcodes are now processed during compilation of your css.

An new shortcode has been added called:

[meta key="(name of arbitrary custom field)" post_id="(optional)"]

This allows you to define a whatever custom fields you like on an individual css post and use them in your css.

Ex. a { color: [meta key="my_color"]; }

So you can define common elements and use them throughout your css.

If you like you can use the option post_id to put those values from another post. So you can have one master css post with your primary colors and such and referance it in other posts.

Credits

Minification code from http://www.lateralcode.com/css-minifier/

Notes on Function

All css is compiled on save unless the transient has expired. If which case a query is run to compile the css durning rendering. I may add option to use either a wp_option or a transient based upon user preferance.

Css is compiled by menu_order. I would like to add more options for better sorting.

There is an options page that outputs the css into a textarea so that you can review the final css in the dashboard.

Email me to request customizations trevor@mailagc.com

Future options may also include the ability to write your css to your theme directory. This plugin currently must be active to keep the css available.

I'm trying to follow the path of Mark Jaquith. Read more here. How to Write a Plugin I'll use

Requires: 3.2.1 or higher
Compatible up to: 3.2.1
Last Updated: 2011-9-10
Downloads: 497

Ratings

4 stars
4 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.