WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Comment Timeout

Closes comments on blog entries after a user-configurable period of time, with an option to make allowances for active discussions.

2.4.1

  • Comment Timeout now works with PHP 5.4.

2.4.0

  • You can now optionally specify a date on which to close comments across the board, and then to re-open them at a later date. This is useful if you are going on holiday, for example, or if you want to take an indefinite break from blogging.
  • Timeout options are now hidden on the admin page when "Close comments" is deselected.

2.3.0

  • Added an option to allow users to reset all per-post settings to their defaults.

2.2.0

  • Comment Timeout now integrates with WordPress's built in comment closing feature. Enabling or disabling comments through the "Discussion" tab will be reflected in Comment Timeout.
  • Old versions of WordPress (prior to 2.8) are no longer supported.

2.1.2

  • Fixed: "allow comments" and "allow pings" options were being disabled when old posts were edited using Quick Edit. See this issue
  • The home page for Comment Timeout is now the Bitbucket repository

2.1.1

  • Fixed layout of files to make automatic upgrades work properly.

2.1.0

  • Added option to disable or modify the message indicating when comments will time out.
  • Added template tags to allow further customisation in the theme.
  • Made the per-post option display correctly on WordPress 2.5 and later.
  • Discontinued support for PHP 4.

2.0.1

  • Fixed a bug that was causing comments to be closed incorrectly when pings were disabled.

2.0

  • Fixed a bug that was allowing comments through from spam bots on old posts.

2.0 alpha 1

  • Initial release of Comment Timeout 2.0. This was a total rewrite with new features:
    • Link Limits, Three Strikes and You're Out moved to separate plugins.
    • Timeouts can now be set on a post-by-post basis.
    • Redesigned admin page.
    • Comments on old posts can be sent to the moderation queue instead of being blocked.

Requires: 2.8 or higher
Compatible up to: 3.2.1
Last Updated: 2013-8-18
Downloads: 13,385

Ratings

4 stars
4.3 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
0,1,0
100,1,1