WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

CodeMirror for CodeEditor

Just another code syntaxhighligher for the theme and plugin editor with CodeMirror.

0.5.6.1

  • Updated CodeMirror to ver. 2.23.
  • Add new themes(Lesser-Dark, XQ-Dark).

0.5.6

  • Updated CodeMirror to ver. 2.22.
  • Add "Highlight matched strings" option.

0.5.5

  • Updated CodeMirror to ver. 2.21.
  • Add "Smart indent" option.
  • Discontinue "Tab mode" and "Indentation for a new line" options.
  • Fix a bug: Selected elements by dragging the mouse isn't displayed inverted correctly.

0.5.3

  • Updated CodeMirror to ver. 2.2-55.
  • Supports "Emacs keybindings".
  • Supports "Vim keybindings".
  • Supports "Highlighting the current line".
  • Re-added "Serach and Replace" box into the toolbar.
  • Added new setting option to show/hide serach and replace box.

0.5

  • Updated CodeMirror to ver. 2.2-39.
  • Supports "visible tab".
  • New "Search" and "Replace" functions.
  • Fix a bug: Using bloginfo() in the wrong way.

0.4.5

  • Added new theme "monokai" and "rubyblue".
  • Added "Update File" button into the toolbar.
  • Renewed "Auto-complete" function.
  • Modified the processing of "Search".
  • Updated CodeMirror to ver. 2.18.

0.4

  • Updated CodeMirror to ver. 2.16-22(including important bug fixes for IE users).
  • Added new variable that has version info of CodeMirror.

0.3.6

  • Added setting link into "Plugins" section.
  • Fix a bug: a missing arrow operator.

0.3.5

  • Rewrote the code using class.
  • Fix a bug: PHP with HTML, Javascript or CSS can't be highlighted correctly.
  • Fix a bug: HTML with Javascript or CSS can't be highlighted correctly.

0.3

  • Added setting panel.
  • Modified stylesheet.

0.2

  • Added Search and Replace functions.
  • Added Auto-complete.
  • The themes become user-selectable in the "fullscreen mode".

0.1

  • This is the initial release.

Requires: 2.8 or higher
Compatible up to: 3.3.2
Last Updated: 2012-3-28
Downloads: 3,949

Ratings

4 stars
4.1 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,2,2 100,2,2 100,1,1 100,1,1 100,1,1 100,2,2 100,1,1
100,1,1
100,1,1 100,2,2 100,2,2 100,2,2 100,1,1 100,1,1
100,1,1
100,2,2
100,1,1