WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

CodeHighlighter

This plugin is a syntax highlighter for source code using GeSHi.

This plugin is a syntax highlighter for source code. It uses GeSHi as fontifier engine.

Usage

  1. Put the code snippet in a <code> tag.
  2. Add the lang attribute to the code tag like the following. <code lang="php">
  3. Add the lineno attribute to the <code> tag after the lang tag if you wish to start at a line other than 1. <code lang="cpp" lineno="42">
  4. If you do not add lang attribute, the <code> tag is handled normally.
  5. If you want to have border, add the style like the following to your .css file. code { border: 1px dotted #ccc; padding: 0.2em 0.5em; }
  6. You can use following languages in lang. abap, actionscript, ada, apache, applescript, asm, asp, autoit, bash, blitzbasic, bnf, c, c_mac, caddcl, cadlisp, cfdg, cfm, cpp-qt, cpp, csharp, css-gen, css, d, delphi, diff, div, dos, dot, eiffel, fortran, freebasic, genero, gml, groovy, haskell, html4strict, idl, ini, inno, io, java, java5, javascript, latex, lisp, lua, m68k, matlab, mirc, mpasm, mysql, nsis, objc, ocaml-brief, ocaml, oobas, oracle8, pascal, per, perl, php-brief, php, plsql, python, qbasic, rails, reg, robots, ruby, sas, scheme, sdlbasic, smalltalk, smarty, sql, tcl, text, thinbasic, tsql, vb, vbnet, vhdl, visualfoxpro, winbatch, xml, xpp, z80

Note: Version 1.9 adds support for <code> tags, however to ensure backwards compatibility support for the <pre> tag will not be removed.

Requires: 2.0 or higher
Compatible up to: 3.4.2
Last Updated: 2012-6-18
Downloads: 9,657

Ratings

4 stars
4.2 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,2,2
50,2,1