WordPress.org

Ready to get started?Download WordPress

Plugin Directory

CloudFlare

The CloudFlare WordPress Plugin ensures your WordPress blog is running optimally on the CloudFlare platform.

1.3.13

  • Clarified error messaging in the plugin further
  • Added cURL error detection to explain issues with server installed cert bundles

1.3.12

  • Removed use of php short-code in a couple of places
  • Added some cURL / json_decode error handling to output to the screen any failures
  • Reformatted error / notice display slightly

1.3.11

  • Adjusted a line syntax to account for differing PHP configurations.

1.3.10

  • Added IP ranges.

1.3.9

  • Made adjustment to syntax surrounding cURL detection for PHP installations that do not have short_open_tag enabled.

1.3.8

  • Fixed issue with invalid header.
  • Updated IP ranges
  • Fixed support link

1.3.7

  • Remove Database Optimizer related text.

1.3.6

  • Remove Database Optimizer.

1.3.5

  • Disable Development Mode option if cURL not installed. Will Use JSONP in future release to allow domains without cURL to use Development Mode.

1.3.4

  • Add in IPV6 support and Development Mode option to wordpress plugin settings page. Remove cached IP range text file.

1.3.3

  • Bump stable version number.

1.3.2.Beta

1.2.4

1.2.3

  • Updated with new IP range

1.2.2

  • Restricted database optimization to administrators

1.2.1

  • Increased load priority to avoid conflicts with other plugins

1.2.0

  • WP 3.3 compatibility.

1.1.9

  • Includes latest CloudFlare IP allocation -- 108.162.192.0/18.

1.1.8

  • WP 3.2 compatibility.

1.1.7

  • Implements several security updates.

1.1.6

  • Includes latest CloudFlare IP allocation -- 141.101.64.0/18.

1.1.5

  • Includes latest CloudFlare IP allocation -- 103.22.200.0/22.

1.1.4

  • Updated messaging.

1.1.3

  • Better permission checking for DB optimizer.
  • Added CloudFlare's latest /20 to the list of CloudFlare IP ranges.

1.1.2

  • Fixed several broken help links.
  • Fixed confusing error message.

1.1.1

  • Fix for Admin menus which are breaking when page variable contains '-'.

1.1.0

  • Added a box to input CloudFlare API credentials.
  • Added a call to CloudFlare's report spam API when a comment is marked as spam.

1.0.1

  • Fix to check that it is OK to add a header before adding one.

1.0.0

  • Initial feature set
  • Set RemoteIP header correctly.
  • On comment spam, send the offending IP to CloudFlare.
  • Clean up DB on load.

Requires: 2.8 or higher
Compatible up to: 3.8.3
Last Updated: 2014-3-15
Downloads: 303,011

Ratings

4 stars
4.5 out of 5 stars

Support

0 of 5 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,5,5 100,1,1 100,1,1
100,1,1
100,4,4
100,1,1 100,1,1 100,1,1
100,1,1
100,3,3 100,1,1
100,6,6 100,1,1
100,3,3
100,2,2 100,1,1 75,4,3
100,1,1 0,1,0 0,1,0 100,1,1
100,2,2
100,7,7
75,4,3 100,2,2 50,6,3 100,1,1
100,4,4 100,4,4
90,10,9
100,7,7 100,1,1
100,2,2
100,1,1 100,4,4
100,1,1
100,4,4
50,2,1
100,2,2 100,3,3 100,1,1