WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Challonge

Integrates Challonge, a handy bracket generator, into WordPress.

Why was this Challonge plugin made?

At first, I needed a WordPress plugin to help with some tournaments I was involved with and nobody had made one or was working on one at that time, so I started making this plugin. Later, I no longer needed a plugin, but I already started the project and people have already noticed. After about a year of life distractions and general procrastination, I completed the first version.

Do I need a Challonge.com account to use this plugin?

Actually, no you don't. (Keep reading!) Without an account, you will only be able to embed tournament brackets into posts and pages with the shortcode, but you will not be able to get any tournament listings with the shortcode or in the widget. You will need a valid Challonge API key, which you can get easily with a Challonge.com account, to use all the Challonge WordPress plugin has to offer. A Challonge.com account is free.

I think I found a bug. What do I do?

Although I do my best to avoid introducing bugs, especially with complexity growing every release, it gets increasingly difficult for me to squish them all before I make a release. That said, please report any bugs you come across in the support forum. I try to get to bug reports quickly and typically, but not always, I get bugs fixed within a week. If I'm already aware of the bug, you will find it in the upcoming release notes on my website.

Can you make the plugin do this?

Got an idea for a new feature or don't like how something already is? Please speak up in the support forum! A lot of the features in the plugin today have been suggested or influenced by the community. If there's something you'd like to see, chances are others may want to see it as well.

How can I help you out?

I do not have a lot of time to actually test everything I put into this plugin. It has already happened where I make something work and the next thing I know, it doesn't work because I forgot one small detail. So, testing this plugin out for me and letting me know what you find would be a big help! If you don't want to do that, you could always donate. Donating will keep me active on this project.

Requires: 3.2 or higher
Compatible up to: 3.9.2
Last Updated: 2014-5-11
Downloads: 2,365

Ratings

5 stars
5 out of 5 stars

Support

0 of 4 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0
100,1,1