WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Celery for WordPress

Celery for WordPress is a WordPress plugin to seamlessly integrate the Celery preorder platform into your WordPress posts and pages.

What is a preorder campaign?

A preorder campaign allows you to being accepting orders before you are ready to ship. You accept credit cards now and charge them only when you are ready to ship.

What types of preorder campaigns are popular?

Sites like Kickstarter and Indiegogo have popularized crowdfunded preorder campaigns. Instead of (or in addition to) one of those, you may prefer extend your reach by running Celery on your WordPress site.

Do I need an SSL certificate?

No SSL is required. Celery presents as an IFRAME or overlay which is secured. You do not need to do anything.

Do I need a merchant account like PayPal or Authorize.net?

No. Celery partners with Stripe for credit card transactions. You need an account with both them.

But I've done credit card stuff before. You definitely need an SSL cert and PCI complaince, right?

No. Celery runs securely in an SSL IFRAME either inline or as a popup on your WordPress site. Your users' card information never touches your site; it goes straight to Celery and then to Stripe. Stripe is the only one that stores card info. Stripe is a PCI Service Provider Level 1, the highest security standard in the industry.

What does all this cost?

Celery takes 2% and Stripe takes 3%.

Requires: 3.0.1 or higher
Compatible up to: 3.6.1
Last Updated: 2013-7-19
Downloads: 814

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.