WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

BuddyPress Group Forum Extras

This plugin is a collection of sub-plugins for group forums. Signatures, bbCode lite, ShortCodes, Ajaxed Quote, RSS Feeds, Forum Index (and Widget), A

What theme edit is required?

Please see Other Notes/Extra Configuration section

I use an external bbPress install along with Group Forums

This has been taken into consideration Signatures will use the same meta table as ck's signature plugin BBCode lite is recommended for external installs (please use Shortcodes if you run a normal buddypress internal forums - then install BBCode Shortcodes by Viper007Bond)

How does a member update their Signature?

xprofile is required and a member may edit their signature under Profile -> Change Signature

Should we be activating both BBCode and Shortcode sub-plugins?

No

Activate the "Forum Extras - BBCode" if you want to parse the bbcode into html prior to database update. (useful if you have external but also ok for internal). I'm a fan of this method as the process happens pre-save but when a user goes back to edit a post - they'll see html

Or

Activate the "Forum Extras - Shortcode" and then Viper's Shortcode BBCode wordpress plugin - this will retain the shortcode bbcode markup in the database. All this does does is enable the shortcode filter hook on the bbpress post content. (buddypress already hooks shortcode filter on activity updates) - Downside to this approach if you ever deactivate the shortcode - you'll see the bbcode markup instead of filtering to the html equivalent but when a user edits a post - they see bbcode instead of html.

I'm using BuddyPress 1.2.5 and Ajax Quote link does not appear

Make sure your theme is up-to-date as well. The action hook bp_group_forum_post_meta was added in 1.2.5

My question isn't answered here

Please contact me at

Requires: PHP 5.2, WordPress 2.9.2, BuddyPress 1.2.5 or higher
Compatible up to: PHP 5.2.x, WordPress 3.0, BuddyPress 1.2.5.x
Last Updated: 2010-6-29
Downloads: 16,763

Ratings

3 stars
3.6 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2 50,2,1 100,3,3 100,2,2 100,1,1
0,3,0
60,5,3
100,1,1
67,3,2
0,2,0
0,2,0
0,1,0
0,2,0
0,1,0