WordPress.org

Ready to get started?Download WordPress

Plugin Directory

BU Navigation

Robust tools for managing hierarchical page content in WordPress. Ideal for blogs with large page counts.

I don’t see the “Primary Navigation” menu! How do I enable it?

The “Primary Navigation” menu item will only appear if the current theme supports it.

Please see this page for more information: Adding Theme Support for Primary Navigation Menus

How do I hide a page from my navigation lists?

While editing your page, uncheck the “Display in navigation lists” checkbox next to the “Visibility” label inside the “Placement in Navigation” metabox. If the metabox is not visible, expand the “Screen Options” panel at the upper right hand corner of the screen and make sure the “Placement in Navigation” checkbox is checked.

My post title is too long for my navigation lists. Is there a way to pick a different label for navigation lists?

While editing your page, enter an alternate navigation label in the “Label” text field inside the “Placement in Navigation” metabox. If the metabox is not visible, expand the “Screen Options” panel at the upper right hand corner of the screen and make sure the “Placement in Navigation” checkbox is checked.

Is there a way to prevent my users from adding top level content to the primary navigation menu?

Visit the “Appearance > Primary Navigation” screen and uncheck the “Allow Top-Level Pages” checkbox. Be sure to click “Save Changes” to save the setting. With this option unchecked, post authors will not be allowed to publish a top level page if the “Display in navigation lists” checkbox is checked.

I’m a theme / plugin developer that would like to take advantage of the navigation library, but I don’t want any of the administrative interface enhancements. Is there a way to disable them?

Yes! The navigation manager interface, content navigation widget, and other plugin features can be disabled on a per-install or theme-by-theme basis.

Please see this page for the details: Configuring Plugin Features

Requires: 3.1 or higher
Compatible up to: 3.9.1
Last Updated: 2014-4-14
Downloads: 3,772

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1