WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Browser Rejector

Notify, or optionally block, site visitors that they are using an outdated web browser, so you can use html5, css3, etc. freely.

3.0

  • Added ability to specify custom browsers/versions to reject. These can be in the form of the browser name, name and version number, rendering engine, etc. and any browsers can be entered.
  • Added ability to manually specify additional browsers to block completely.
  • Updated Chrome version to 25
  • Updated Firefox version to 19

2.11

  • Fixed major security vulnerability, update immediately
  • Confirmed WordPRess 3.5 Compatibility
  • wp_footer() action hook is now required again
  • Updated Firefox version to 17

2.10

  • Updated Chrome Version to 23
  • Compressed all plugin images to reduce plugin size by 330kb
  • Fixed bug where IE9 was easily blocked (it's standards are sufficiently modern to not warrant blocking)

2.09

  • Updated Internet Explorer Version to 10
  • Updated Firefox Version to 16

2.08

  • Added German translation (thanks to Axel Kriewel for providing)
  • Placed the chromeframe activation tag in a conditional comment so the code validates (it only does stuff on IE anyway)
  • Fixed IE link (Microsoft changed the url)
  • Translations of browser names are now displayed in the output as well as the preview (names usually aren't translated, but for when they are)
  • Fixed issue where an extra page opened every time a browser icon was clicked, this was something residual from the jreject jquery plugin
  • Ability to reject IE9 has been implemented (in comments) in anticipation of IE10, to be released later this month. This ability will remain commented out because there is little good reason to block IE 9, but is there in case you need to distinguish between 9 and 10.
  • Fixed a couple other minor bugs

2.07

  • Fixed minor versioning error
  • Updated Google Chrome to version 22

2.06

  • Fixed a HUGE bug, and removed a ton of associated workarounds and bugs for IE 6 and 7
  • Switched the icon set to not using transparent PNGs, because of a lack of suport by IE6 :( they are still PNGs which is the best graphics format for these icons though
  • Improved the option to completely block access only on certain browsers, you can now choose ie6/7 and firefox3 independently (option is available only when allowing visitors to close the window universally)
  • Removed dependence on wp_footer action hook, only wp_head is required now
  • Officially dropping all suport for IE5 (which no one uses), as it isn't supported by jQuery
  • Firefox version actually updated to 15 (oops!)
  • Added the ability to translate (use the .pot and send me the .po and .mo if you'd like to help out)
  • Wrote Spanish Translation (es_ES and es_PE)
  • Added Persian Translation (thanks to Rezaei for writing)

2.05

  • Fixed several minor bugs. Thanks to everyone who pointed them out either through the support forums or email!

2.03

  • Added ability to let users close the rejection window on all browsers except IE6/7; this allows for greater flexibility depending on the severity of browser deprecation...

2.02

  • Firefox version displays updated to 15. I know these details are somewhat OCD, but I will try to keep these updated as new browser versions are released. Let me know if I miss a release. Most future updates will be of this type.

2.01

  • Fixed a long list of bugs regarding rejection window display in Internet Explorer 6 and 7
  • After studies with IE5, it has been determined that it will not be supported by this plugin actively. The browser is rejected, but the rejection window display is... weird (not that ANYONE uses IE5 anyway)

2.00

  • Fixed major bug with rejection in IE 6 and 7.
  • Automatically includes the code to render the site in chrome frame (when installed in IE), wp_head and wp_footer action hooks are now required
  • A couple other minor adjustments

1.00

  • First publically available version of the plugin.
  • Compatible with WordPress 3.3.0 through 3.4.0
  • Listed browser versions include: Chrome 21, IE9, Firefox 14, Opera 12, and Safari 6

Requires: 3.3.0 or higher
Compatible up to: 3.5.2
Last Updated: 2013-9-4
Downloads: 5,471

Ratings

4 stars
4 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,2,2 50,2,1
100,1,1
100,1,1