WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

BrainPOP UK Video widget

BrainPOP UK widget to embed a learning video in your wordpress blog

Q: Is this the official BrainPOP UK Plugin? A: Yes. It has been developed in partnership with the wonderful http://primaryblogger.co.uk/ who run a free, easy to adopt WordPress Blog service for UK Primary School teachers, pupils and classes.

Q: Can I choose the movie it shows? A: No. But the movie regularly changes and is hand picked by the BrainPOP UK team.

Q: Is there anyway to resize the plugin to be less or more than 300px? A: It is currently set at 300px by 300px. We are working on a way to pick from multiple sizes.

Q: Can I request a movie to be shown in the POPbox? A: There's no harm in emailing us info@brainpop.co.uk to suggest a featured movie, but remember that the featured movie is the same for everyone.

Q: How do you choose which movies to show? A: Featured movies are often linked to significant occasions (Martin Luther King movie on August 28th) cultural events (World Cup movie) or to help schools explain world events (Floods movie during the recent flooding in Pakistan). If you want to pick and choose from all our movies to show to your class and kids then you will need to subscribe to http://www.brainpop.co.uk/

Q: What age range is BrainPOP aimed at? A: BrainPOP UK is aimed at 7-14 year olds. But you're never too old to learn!

Q: What subjects will the POPbox cover? A: BrainPOP UK is cross curricular and covers Science, Humanities, Maths, English, PSHE & Citizenship, Art and Design & Technology.

Q. The width/height of the widget didn't save the first time around. A. Try save it again, if this doesn't work try to remove/re-add the widget.

Q. Where can I get extra support? A. At the developers website http://mclear.co.uk/brainpop-wordpress-plugin

Requires: 2.0 or higher
Compatible up to: 3.1.4
Last Updated: 2010-10-7
Downloads: 670

Ratings

3 stars
3 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1