WordPress.org

Ready to get started?Download WordPress

Plugin Directory

BNS Early Adopter

Show off you are an early adopter of WordPress

0.8

  • Released May 2014
  • Added optional shortcode_atts filter variable
  • Added plugin_data method
  • Added new FAQ referencing the /bns-customs/ folder location
  • Define location for BNS plugin customizations
  • Move to use generic folder for all "BNS" plugins to use
  • Updated required version of WordPress to 3.6
  • Updated compatibility version
  • Updated copyright years

0.7.1

  • Released December 2013
  • Code Reformatting and version compatibility update

0.7

  • Released July 2013
  • Corrected Administrator Only conditional and added admin only classes
  • Added filter for "Administrator ONLY View" text

0.6.1

  • Released April 2013
  • Fixed conditional logic used to display plugin
  • Refactored where $ea_display boolean value is set

0.6

  • Release February 2013
  • Added code block termination comments
  • Added more i18n compatibility
  • Change to PHP5 style class code format
  • Changed constructor function name (BNS_Early_Adopter_Widget) to __construct (i.e.: PHP5 code format)
  • Moved all code into class structure
  • Moved bnsea_display out of widget method
  • Pushed minimum required WordPress version to 3.2 to handle PHP5 requirement
  • Renamed BNSEA_Scripts_and_Styles to scripts_and_styles

0.5

  • Release November 2012
  • Documentation updates
  • Optimized output buffer code used in the shortcode function
  • Remove load_plugin_textdomain as redundant

0.4.2

  • Documentation updates
  • Programmatically add version number to enqueue calls

0.4.1

  • Compatible with WordPress 3.4.1

0.4

  • Fix issue of plugin not displaying with stable versions

0.3.1

  • Added margin: 0 to 'h3.bnsea-output'
  • Updated screenshot

0.3

  • Added release candidate option

0.2

  • Added conditional display widget check: if no version is checked, or no matching version is found the widget will not be displayed.
  • Cleaned up grammar conditional statements
  • Added only show administrators option
  • Added shortcode support
  • Added screenshot of default widget option panel

0.1

  • Initial Release.

Requires: 3.2 or higher
Compatible up to: 3.9.1
Last Updated: 2014-5-3
Downloads: 558

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1
100,1,1 100,1,1
100,1,1 100,1,1
100,1,1
100,1,1 100,1,1
100,1,1
100,1,1
100,1,1 100,1,1 100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1 100,1,1
100,1,1