WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WP-Base64 Encoder/Decoder

Enables you to encode parts of your post in base64.

Can I include html tags inside '<base64>' and '</base64>' tags?

Yes, you can include html tags, they will be encrypted too.

I'm using an older version of this plugin wich uses '<!--base64-->' and '<!--/base64-->' tags. Do I have to edit all posts and change that tags to the new ones?

This plugin has retro-compatibility, this means that you don't have to change that old tags, they will work too. But if you wish you can update the database replacing the old tag format to the new tag format with just one click.

Why you don't provide a Visual editor quicktag button for the plugin?

That's because I haven't learned yet how to add it, but I'm working on that.

When I switch from HTML Editor to Rich Text Editor and back again to HTML Editor, Base64 tags are deleted automatically. Why is this?

Rich Text Editor deletes all html-like tags that are not standard html tags. It will be solved when the Visual quicktag button is implemented.

Is there any way to get this plugin translated into other languages besides english and spanish?

Of course. Check for base64-encoderdecoder.pot file, create a copy and rename it to base64-encoderdecoder-xx_XX.po, replacing xx_XX with the corresponding shortcode for your language. Then translate it using poEdit. When you're done with translation, copy base64-encoderdecoder-xx_XX.po and .mo files to the place where the plugin is installed, and finally change the language setting on wp-config.php.

If you want to contribute with your .po and .mo translations, go to the Plugin Homepage and contact me sending that files. I'll add them as soon as possible.

I think your plugin is great. How can I thank you besides rating it?

I thought you wouldn't ask. You can send me some bucks via PayPal, even USD$1 it's OK.

Requires: 2.0.5 or higher
Compatible up to: 2.9.2
Last Updated: 2009-8-1
Downloads: 1,557

Ratings

4 stars
4.7 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1