WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Arconix Shortcodes

Arconix Shortcodes provides a number of useful design elements like buttons, boxes, tabs and toggles to help compliment any website.

What is compatibility mode?

Compatibility mode adds a prefix to all the plugin's shortcodes. This was put into place to help avoid conflicts with other themes or plugins that used the same shortcode (like [button] or [box])

How do I enable compatibility mode?

Place the following code in your theme's functions.php file:

define( 'ACS_COMPAT', true ); // Arconix Shortcodes Compatibility Mode

Now when adding a shortcode, just make sure they start ac- (i.e. [ac-box]content[/ac-box]

Where can I find more information on how to use the shortcodes?

How can I collapse all the accordions?

While you can set the accordions to all collapse when the page is first loaded, the jQuery Tools script that powers these accordions does not support closing all the accordions once one has been opened.

The Accordions/Tabs/Toggles isn't working

While you can certainly start a thread in the support forum, there are some troubleshooting steps you can take beforehand to help speed up the process. 1. Check to make sure the javascripts are loading correctly. Load the page with the malfunctioning shortcode in your browser and view your page's source (usually CTRL + U). Look for jQuery, jQuery Tools and Arconix Shortcodes JS files there. If you don't see jQuery Tools or the Arconix scripts at all (they're somewhere near the bottom of the page), then your theme's footer.php file is likely missing <?php wp_footer(); ?>, which is neccessary for the operation of mine and many other plugins. If you're unable or unwilling to resolve the issue yourself, contact the theme developer for assistance. 2. Check to make sure only one copy of jQuery is being loaded. Many times conflicts arise when themes or plugins load jQuery incorrectly, causing it to be loaded multiple times in multiple versions. In order to find the offending item, start by disabling your plugins one by one until you find the problem. If you've disabled all your plugins and the issue still persists, try switching to a different them, such as twentyten or twentytwelve to see if the problem is with your theme. Once you've found the problem, contact the developer for assistance getting the issue resolved.

I have a problem or a bug

Check out the WordPress support forum or the Issues section on Github

I have a great idea for your plugin!

That's fantastic! Feel free to submit a pull request over at Github, or you can contact me through Twitter, Facebook or my Website.

Requires: 3.4 or higher
Compatible up to: 3.8.3
Last Updated: 2014-1-15
Downloads: 26,151

Ratings

4 stars
4.5 out of 5 stars

Support

1 of 3 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1 100,2,2 67,3,2 100,1,1
100,1,1
100,1,1 100,4,4
100,1,1 100,1,1 100,1,1
100,1,1
50,2,1
100,2,2
100,1,1 100,1,1
100,3,3
100,1,1
100,1,1 0,1,0
100,2,2
100,1,1
100,1,1
50,2,1