WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Apocalypse Meow

A simple, light-weight collection of tools to help protect wp-admin, including password strength requirements and brute-force log-in prevention.

1.6.0

  • In honor of Heartbleed, there is now a tool for resetting all user passwords en masse;

1.5.0

  • Allow alternate $_SERVER variables for proxy installations (thanks jjfalling);
  • Minor code clean up;

1.4.5

  • Warn administrators on settings page of potential proxy/intranet-type issues;
  • Only show .htaccess options on Apache servers;
  • Use wp_die() for Apocalypse screen;
  • Database maintenance on by default;

1.4.4

  • Minor update, file clean up.

1.4.3

  • Minor bug fix ensures variables are declared at activation;

1.4.2

  • Replace deprecated $wpdb->escape() with esc_sql();

1.4.1

  • Minor update, replacing a couple functions that are deprecated as of PHP 5.5.0;

1.4.0

  • Added log-in jail page to view currently banned IPs;
  • Added ability to temporarily pardon a banned IP;
  • Log-in history now displayed in viewer's timezone;

1.3.6

  • Bug fix: call-time pass-by-reference warning/error in PHP 5.3+;

1.3.5

  • Changed the fail window unit from seconds to minutes;
  • More efficient logging of Apocalypse triggers;
  • Simplified Apocalypse page options;
  • Bug fix: database upgrade procedure skipped;

1.3.4

  • Lowered data retention minimum to 10 days;
  • Option to manually clear data;
  • Uninstallation now removes all plugin data/settings;
  • Option to disable theme/plugin editor;
  • Prevent installation on WPMU blogs;
  • Use $_SERVER instead of getenv() as it is compatible with more server environments;
  • Miscellaneous small bug fixes;

1.3.3

  • Added log-in statistics;
  • Storing UA string with log-in attempt is now optional (default disabled);
  • Log-in protection settings now hidden if log-in protection is disabled;
  • Database maintenance settings now hidden if maintenance is disabled;

1.3.2

  • Code clean up: use existing WP CSS for log-in history table;
  • Set 403 status header when displaying Apocalypse screen;

1.3.1

  • Compatibility with 3.5;
  • Code clean up: all queries now run through $wpdb;

1.3.0

  • Added the ability to rename the default WordPress user to something less predictable;
  • Minor bug fixes;

1.2.0

  • Added the ability to disable the direct execution of PHP scripts in wp-content/;
  • Re-organized the settings page;

1.1.0

  • Added customizeable page title and content for the Apocalypse page;
  • Added Apocalypse page display logging;
  • Improved timestamp handling;
  • Un-embedded kitten graphic for improved support with older browsers;

1.0.0

  • Apocalypse Meow is born!

Requires: 3.4 or higher
Compatible up to: 3.9.2
Last Updated: 2014-8-6
Downloads: 9,539

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,2,2 100,2,2 100,1,1
100,2,2 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,2,2 100,1,1 100,3,3
100,1,1
100,1,1
100,1,1