WordPress.org

Ready to get started?Download WordPress

Plugin Directory

AllWebMenus WordPress Menu Plugin

Requires commercial (paid) software: AllWebMenus PRO (v5.3.926+)

1.1.22 (requires AllWebMenus Build #926 or above)

  • Supports different Site Address from the WordPress Address, plus different subfolders from the default ones.

1.1.21 (requires AllWebMenus Build #926 or above)

  • Supports the "Genesis Framework" (the menu is now linked to the posts/pages automatically, without any custom hook required).

1.1.20 (requires AllWebMenus Build #926 or above)

  • Improves the sessions usage on servers where certain permissions are not granted.

1.1.19 (requires AllWebMenus Build #926 or above)

  • Makes the integration with AllWebMenus Pro much simpler regarding the compiled menu name and menu positioning (no need to explicitly specify them in AllWebMenus; they are based on the WordPress plugin settings).
  • Improved the Menu Structure Code output.

1.1.18 (requires AllWebMenus Build #884 or above)

  • Fixes a "missing argument" bug when PHP error messaging was set on STRICT mode.

1.1.17 (requires AllWebMenus Build #884 or above)

  • Supports responsive menus.

1.1.16 (requires AllWebMenus Build #884 or above)

  • Improved multiple menus support.

1.1.15 (requires AllWebMenus Build #884 or above)

  • Added support for WordPress 3.5.

1.1.14 (requires AllWebMenus Build #884 or above)

  • Fixed an error saying "Wrong filename" when trying to upload the compiled zip.

1.1.13 (requires AllWebMenus Build #884 or above)

  • Improved the interface & workflow of the plugin.
  • Added a "welcome" page.

1.1.12 (requires AllWebMenus Build #884 or above)

  • Fixed an issue related to WP not allowing zip files to be uploaded.

1.1.11 (requires AllWebMenus Build #884 or above)

  • Fixed an issue related to folder permissions.

1.1.10 (requires AllWebMenus Build #884 or above)

  • Fixed a case where UL/LI menus with JS Genre did not work.

1.1.9 (requires AllWebMenus Build #884 or above)

  • Improved the security protection.

1.1.8 (requires AllWebMenus Build #884 or above)

  • Fixed a minor security issue.

1.1.7 (requires AllWebMenus Build #884 or above)

  • Added support for ULLI and CSS menus.

1.1.6 (requires AllWebMenus Build #862 or above)

  • Fixed a problem caused by the "Atahualpa" theme.

1.1.5 (requires AllWebMenus Build #862 or above)

  • Fixed a case that produced a 404 error on "actions.php".

1.1.4 (requires AllWebMenus Build #862 or above)

  • Fixed a wordpress security issue.

1.1.3 (requires AllWebMenus Build #862 or above)

  • Added more error-checks to avoid some pitfalls.

1.1.2 (requires AllWebMenus Build #862 or above)

  • Compatible with PHP 4 (previously required PHP 5).

1.1.1 (requires AllWebMenus Build #862 or above)

  • Added upload ZIP file functionality.
  • Added the abilty to add and remove menus.
  • Now combatible with WordPress widget system.
  • Made it possible to hook to WordPress Theme Menu Locations.

1.0.24 (requires AllWebMenus Build #818 or above)

  • Minor interface improvements.

1.0.23 (requires AllWebMenus Build #818 or above)

  • Corrected a problem with links not properly working for WordPress 3+ custom menus.

1.0.22 (requires AllWebMenus Build #818 or above)

  • Corrected a problem with empty groups generated for each item in "dynamic-type" menus.

1.0.21 (requires AllWebMenus Build #818 or above)

  • Corrected the Add/Edit menus link.

1.0.20 (requires AllWebMenus Build #818 or above)

  • Added support for WordPress 3+ menus.

1.0.19 (requires AllWebMenus Build #818 or above)

  • Fixed an issue were adding "related posts" produced a JavaScript error.

1.0.18 (requires AllWebMenus Build #818 or above)

  • Fixed a compatibility issue when uploading images with WordPress 2.9.2.

1.0.17 (requires AllWebMenus Build #818 or above)

  • Easier interface.
  • Multiple menus (use up to 5 different menus on your posts or pages), with separate settings per menu.
  • New option: "Dynamic" Menu Type (AllWebMenus provides the menu style while all items are populated based on blog's content).
  • New option: "Static" Menu Type (both menu style and content are provided by AllWebMenus, allowing full customization of the menu).
  • New option: "Mixed" Menu Type (combines both the "Dynamic" and "Static" Menu Types in a single implementation * you can have both WordPress and non-WordPress items on your menu!).
  • Integration with the latest "Related Posts" (YARPP) plugin. It dynamically adds a "Related Posts" item at the end of the Main Menu, with a submenu that contains posts related to the post you are currently viewing!

1.0.12 (requires AllWebMenus Build #810 or above)

  • Fixed an issue related to the use of UL/LI with Automatic Highlight.
  • This version is now based on version 2.0.17 of the Server-Side Menus API Add-in.

1.0.11 (requires AllWebMenus Build #804 or above)

  • Fixed an issue where the Automatic Highlight Feature did not work properly.
  • This version is now based on version 2.0.16 of the Server-Side Menus API Add-in.

1.0.10 (requires AllWebMenus Build #800 or above)

  • Added support for "Unlimited Domains" licenses.
  • Added support for the Automatic Highlight Feature.
  • This version is now based on version 2.0.15 of the Server-Side Menus API Add-in.

1.0.9 (requires AllWebMenus Build #772 or above)

  • This version is now based on version 2.0.14 of the Server-Side Menus API Add-in (which adds support for new features of sliding submenus).
  • Fixed a bug with menu filenames that include a space or "-".

1.0.4 (requires AllWebMenus Build #758 or above)

  • This version is now based on version 2.0.9 of the Server-Side Menus API Add-in (which fixes an incompatibility between the API javascripts and MooTools, if used on your website).

1.0.3 (requires AllWebMenus Build #758 or above)

  • The GUI of the Add-in has been enhanced.

1.0.1 (requires AllWebMenus Build #754 or above)

  • Initial release.

Requires: 2.3 or higher
Compatible up to: 3.9.2
Last Updated: 2014-8-22
Downloads: 40,524

Ratings

3 stars
3 out of 5 stars

Support

0 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
50,2,1
0,2,0 0,1,0
100,1,1 100,1,1
100,1,1
0,1,0