WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Advanced Random Post Thumbnails Widget

Widget displays thumbnails from random posts. Thumbnails can be grabbed from all posts, from posts from selected categories or selected from categorie

1.4

  • Added option to link the category title to the category it represents.

  • Added option to link each thumb to its post's category instead of to the post to which it belongs.

1.3

  • Added category drop-down menu for selecting either All Categories or a single parent category or a single child/grandchild category.

  • Added option to display the category title atop of the block of thumbs when the displayed thumbs all belong to the same category.

  • Added a drop-down box for font typography selection for the category title - header (h1-h6), paragraph and strong.

1.2

  • Fixed error with WordPress repository upload (hopefully)

1.1

  • Added the option to set the images to display as either rows or columns (in HTML speak, inline or block)
  • Added a 3-column, 1 row tabled image layout (can display up to 20 images at a time).
  • Added left and right side buffer spaces.

1.0

  • First release.
  • Based on the Advanced Random Post Widget by Yakup GĂ–VLER. Thank you Yakup for writing the original script.
  • Changes to the original script include:
  • Removed the ability to display the title and excerpt from the post a thumbnail is generated from,
  • Changed post display type from an unordered list (ul) to regular divs (div),
  • Added the option to specify thumbnail margins,
  • Added class names to generated thumbnails and their container div. See FAQ for class details,
  • Modified various class and function names to permit both this widget and the Advanced Random Posts Widget to be installed into the same site simultaneously without conflict,
  • Made minor changes to the widget's language,
  • Made various other changes that I can't recall.

Requires: 2.8 or higher
Compatible up to: 3.3.2
Last Updated: 2011-12-19
Downloads: 24,376

Ratings

3 stars
3.7 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 100,1,1 100,2,2
100,2,2
50,2,1
50,2,1
100,2,2
50,2,1
100,2,2
50,2,1
100,1,1
0,1,0
100,1,1
100,1,1