WordPress.org

Ready to get started?Download WordPress

Plugin Directory

AcademicPress

Turn your Blog into an academic publishing site

Software Requirements

  1. PHP 5.2 (no additional libraries required)

Install

  1. Download and install from within WordPress
  2. Choose: Activate or Network Activate
  3. Configure AcademicPress

Notice

Use of this plugin assumes acceptance of this plugin's license and its Terms of Use, to be found in license.txt.

Requires: 2.8 or higher
Compatible up to: 3.4.2
Last Updated: 2012-10-28
Downloads: 2,827

Ratings

5 stars
5 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
0,2,0