WordPress.org

Ready to get started?Download WordPress

Plugin Directory

2046's Loop widget

2046's loop widget boosts you website prototyping.

How can I use it`?

First you have to have some dynamic sidebars defined. Some themes have them registered already, but I doubt they have them in the main content area where this loop widget meets it's intention. (Most of the templates have them only in so called sidebars, or header. Widgets are commonly are used for category listing, tag cloud, Facebook features etc.) The dynamic sidebar is a "slot" where you can put widgets with countless features.

Log in to your admin and go to Appearance>Widgets. If you don't see the Widgets item, then your template hes no sidebars defined. How to register sidebar.

What do you suggest?

What I do is, that I register sidebars at least one per logical block in the webdesign layout (template). Then using 2046's loop widget you can place the content loops anywhere you like and how many you like. You can interlace them by any other widgets. By drag & dropping the widgets into the dynamic sidebar areas you can easily define the structure of the whole website.

What about design?

If your template has the most basic CSS setups then you don't have to wary. Widgets will nicely follow the actual template CSS rules and will obediently follow the predefined design. If you still needs some exceptions for this or that widget or it's element, every widget has it's own CSS "id" or "class" so you can easily bend them to your needs.

I do not see what I have expected to see.

Well the widget is fairly complex. Check if the restrictions are not beating each other and also check if the content you expect there really is sortable the way you like it to be. If none of these checks works, then let me know on the forum, I'll do my best.

Known bugs

  • When you are in the widget setting in the part [elswhere]>[selected taxonomy] then the taxonomy fields are sometimes multiplied. This happens when always you drag&drop the widget. Don't wary this is just a Javascript skin effect. If you save the widget, or you come back next time, it will be fine. (I'm working on it).

Requires: 3.1 or higher
Compatible up to: 3.4.2
Last Updated: 2012-11-26
Downloads: 8,056

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1