WordPress.org

Ready to get started?Download WordPress

Ideas

POP3 over SSL support (enables post via mail from Gmail)

  1. akulavolk
    Member

    12345

    WordPress currently doesn't support blog by e-mail via POP3 over SSL. This is especially a problem for Gmail accounts since they won't work over regular POP3 (non-SSL). Also, having SSL is always a bonus as far as security is concerned.

    This feature would be REALLY nice to have.

    I've seen a few proposed workarounds for this, including using Postie and wp-gmail.php. But neither seem to be supported/updated anymore, and I couldn't get them to work.

    http://wordpress.org/support/topic/107731?replies=6
    http://wordpress.org/support/topic/119392?replies=2

    In reference to the last posts on both: simply using ssl://pop.gmail.com as server address doesn't work. Since there's no SSL support in WordPress, you just get an error from Gmail's server.

    Blog via e-mail is ridiculously easy in Blogger, but I really like WordPress. It would be nice to see this implemented in WordPress so you just put your account name, server, and password and you have instant blogging (text & images at least) via secure SSL e-mail for easy mobile blogging.

    Posted: 6 years ago #
  2. techguy
    Member

    I'm really surprised this hasn't been addressed sooner. I'd like to throw my hat in the ring to support this feature request. Sure many phones are getting nice blogging clients, but email is still more ubiquitous.

    Posted: 5 years ago #
  3. SteveLV702
    Member

    interesting cause I used the ssl://pop.gmail.com as the server address and first it didnt work but the error message I got explained the issue PHP wasn't compiled with SSL Support so I compiled it and tried again and I then got this when I ran wp-mail.php

    Author = steve.lawrence@guysgonedigital.com

    Author: 1

    Posted title: test3

    Mission complete, message 1 deleted.

    then went to my blog and the test blog was bosted so it works.

    Posted: 5 years ago #
  4. ifsabutlerweb
    Member

    i just tried this and i got the status to work but it did not post. instead it was "pending review". stevelv702- did you need to toggle any other settings than "writing settings"? i would love for this to work!

    Posted: 4 years ago #
  5. SteveLV702
    Member

    And your marked as a Administrator in your WordPress system? you sending from the email address in your profile? really dont see why would be putting in review unless its not a new article post and is a comment and you have the setting that all comments must be moderated enabled...

    Posted: 4 years ago #
  6. Jen Mylo
    Key Master

    Post by email feature is slated to be removed from core and turned into a core plugin.

    Posted: 4 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.

  • Rating

    12345
    6 Votes
  • Status

    This is plugin territory