WordPress.org

Ready to get started?Download WordPress

Ideas

Plugin and Theme Directory: Filter by compatibility

  1. amenthes
    Member

    12345

    Let users filter plugins that are no longer supported. I'd imagine something like this: Developers have to supply specific versions in their metadata like
    Compatibilitylist: 2.6.0 2.6.1 (and so on) 2.7.1
    Users could then mark a checkbox "Only show plugins compatible with the current version of wordpress".

    The WordPress-Internal search might filter the incompatible one automatically.

    Of course, we would see many updates to plugins which would only be used to "bump" the version, but then again you could easily see which plugins are actively maintained and which not.

    Posted: 5 years ago #
  2. saltlakejohn
    Member

    12345

    Oh boy, do I look forward to this! There are plugins and themes that just "hang around", given little or no attention from their owners, sort of like stray pets. At present, interested parties can only pick them up and try them. If we knew an offering hadn't yet been approved for 2.7, we could save time and avoid risky behavior.

    Posted: 5 years ago #
  3. amenthes
    Member

    12345

    This could also be the end of the codex-articles where the compatible plugins have to be listed by the users - but with the difference that you get all the information in one place.

    Posted: 5 years ago #
  4. syncbox
    Member

    12345

    PLEASE include this with the next release of WordPress... PLEASE! PLEASE! PLEASE! PLEASE!

    Reward those developers who DO take the time to maintain their plugins by listing ONLY those compatible with the latest release on the first page of this part of WordPress.org's site...

    Posted: 4 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.

  • Rating

    12345
    7 Votes
  • Status

    Duplicate of another idea