WordPress.org

Ready to get started?Download WordPress

Ideas

Improve the plugin search DRASTICALLY

  1. mataga
    Member

    Hi,

    This is my first idea ever. I have been annoyed about this for a couple of years so now was the time to say something :)

    Basically, I think the plugin search is WAY TO simple for WordPress imo, and I am starting this thread so that we perhaps could work out a good solution?

    I will contribute with a few things

    Features that would ROCK:
    * Filter out plugins that is incompatible with my version.

    Posted: 3 years ago #
  2. Micah Cooksey
    Member

    The only thing is that some plugins that say they're only compatible up to a previous version than yours actually work fine. It's pretty hard to say whether or not it will work for everyone. Since there are issues such as conflicts with other plugins that make compatibility statistics vary.

    Posted: 3 years ago #
  3. Edified
    Member

    There's 10,000 plugins and no good way to find the one you need.

    Version issues are only the beginning (but it's a good beginning)
    -Filter by compatibility
    -Filter by recency of update
    -Filter by multiple tags
    -Filter by rating

    You should be able to do a query that finds plugins compatible with WP2.9 to 3.0, updated within the last 2 months with the tags "ajax" and "comments", excluding the tags "dirty hack" rated 4 stars or higher.

    Of course that query would come up blank, but you get the idea ;)

    The same for themes.

    Posted: 3 years ago #
  4. Jen Mylo
    Key Master

    Duplicate idea.

    Posted: 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.

  • Rating

    12345
    4 Votes
  • Status

    Duplicate of another idea