WordPress.org

Ready to get started?Download WordPress

Ideas

Fill last page of comments

  1. billseymour
    Member

    Presently, WordPress appears to fill pages of comments by "fill first page of comments". This produces the following type of display: if 9 comments, Discussion set for 4 comments per page, and default to Last page (most recent comments), one gets:
    Default page: comment 9 only
    Page 2: comments 8,7,6,5
    Page 1: comments 4,3,2,1

    This makes very little sense to a visitor, who sees that there are 9 comments, but only sees one comment (#9) on the landing page, and must immediately page through the comments to even see #8.

    Suggestion: Provide checkbox/method for a user to select "Fill Last Page of Comments". In this way, one "fills the last page fully, then fills the next page". This would produce:

    Default page: comments 9,8,7,6
    Page 2: comments 5,4,3,2
    Page 1: comment 1

    This occurs (non-threaded) in two plugins that are no longer being developed:
    Paged-comments http://www.keyvan.net/code/paged-comments/
    Paginated-comments http://www.badspiderbites.com/paginated-comments/

    Thanks! --Bill

    Posted: 3 years ago #
  2. Justin Tadlock
    Member

    12345

    I don't want to see an option for this, but it should be fixed. One of the reasons I've steered clear of paged comments is because of this. There's not much point in displaying a single comment on the actual post page and having all the other comments hidden away.

    Posted: 3 years ago #
  3. billseymour
    Member

    By "fixing" this, I imagine you mean that:

    If someone in Discussion selects "Last page displayed by default", they should, without needing to use an Option, properly get the last page fully filled (ie, #9,8,7,6 in my example).

    That is an even better solution than an Option to Fill or not. I, like you, see a problem in a 9 comment post, showing 4 at a time, have a landing page show only 1 comment (#9), and require paging to get to the next comment (#8,7,6,5).

    The landing page clearly should be fully filled (#9,8,7,6).

    Thanks. Good thought.

    Posted: 3 years ago #
  4. MK Safi
    Member

    12345

    Anyone familiar enough with the API to know if this can be fixed with a plugin?

    Posted: 3 years ago #
  5. MK Safi
    Member

    12345

    I think I managed to fix this problem. Let me know if the solution works for you.

    Posted: 3 years ago #
  6. billseymour
    Member

    M.K.-

    Bravo!- your solution is working just fine. A few notes:
    - Your plugin works with Greg's Threaded Comment Numbering plugin.
    - Your plugin works with a custom callback in wp_list_comments

    Good work. Thanks so much.

    (Just in case someone wanted to see code for both points above. In comments.php, replacing wp_list_comments() with your code and modified wp_list_comments )

    if (class_exists('Walker_Comment_Wink'))
    $walker = new Walker_Comment_Wink();
    else
    $walker = '';

    wp_list_comments(array('walker' => $walker, 'callback' => 'my_custom_callback_func'));

    Posted: 3 years ago #
  7. margje
    Member

    @billseymour,

    This is exact what i'm looking for but can't get it work. Is it still possible to use your plugin?

    Thanks in advance!

    Marje

    Posted: 1 month ago #

RSS feed for this topic

Reply

You must log in to post.

  • Rating

    12345
    8 Votes
  • Status

    This idea is under consideration