WordPress.org

Ready to get started?Download WordPress

Ideas

Enable or disable comments for new pages

  1. Paul
    Member

    It's a very simple modification.

    Just add a select box when you made and selected a new page. With this selectbox you can enable or disable comments for this specific page.

    Thats all!!

    Best regards from Paul

    Posted: 2 years ago #
  2. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod

    You can already do that.

    You may need to click 'Screen Options' to show the discussion meta box, but there's a way to disable comments per page.

    Now if you're saying 'I want comments off on my PAGES but not my POSTS' that's something else :)

    Posted: 2 years ago #
  3. Paul
    Member

    Yes,

    I want comments off on my new PAGES, but not for my POSTS.

    I tried everything to get this done, but without success.

    I am using the last Dutch version 3.3.1 of WordPress.

    Posted: 2 years ago #
  4. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod

    You can't do it automagically (yet) but you can do it manually. Once you make the page, go in and turn off comments.

    Seriously that works :) Sucks that it's manual, though :/

    I'm pretty sure this idea's out there, btu I can't find it.

    Posted: 2 years ago #
  5. Or! Hook to a publish_post, see if it's a page and turn commenting off programmatically. I think this is 100% plugin territory.

    Posted: 2 years ago #
  6. Paul
    Member

    Thank you for all your reply's, but whatever I try, it doesn't work.
    Somebody told me to change the code in page.php from my theme. He told me: Remove this code: <?php comments_template( '', true ); ?>
    I did and guess what. You still can add comments on my new pages!
    Could it be a bug in the Dutch WordPress?

    Edit post:
    I am positive it is a bug! I disabled it and still I have comments on my pages.

    Posted: 2 years ago #
  7. Paul
    Member

    Ok, problem solved.

    I created a new page.
    In 'screen options' you can select whatever you want to see on the page you are currently working on. Like "comments".
    But what is very important when you select this options that you have to "refresh" the page. After that the option appear on the page you are editing.
    If you deselect "comments" they disappear from your created page. Pheww. At last.

    WordPress needs to do something about this. It is not userfriendly like this.

    Case closed.

    Posted: 2 years ago #
  8. Keyur
    Member

    Hello, I have unchecked Allow people to post comments on new articles and also go to Posts -> Select all posts -> Edit -> Don't allow comments and Pings -> Update.
    Still i am getting comments daily .
    Any Solutions please ?

    Posted: 1 year ago #
  9. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod

    Post here for help: http://wordpress.org/support/

    Posted: 1 year ago #
  10. journalt
    Member

    Can I get some clarity on this? I have been using WP for ~8 months or so and never get any comments on my posts-no matter how many views I get, it seems. Looking up some documentation recently about disabling comments, I discovered that if I have the Discussions box ticked on "screen options" there is an option to turn on comments--never knew this before, but it seems that unless I check it comments are automatically turned OFF. Is this why no one comments on my posts?

    Can this possibly be the BEST WordPress has to offer on this? At the top of the post it says "Leave a comment" so I just assumed comments were enabled. But it appears now that they are automatically disabled and must be turned on for every page. Is this right or am I missing something ? I have comments enabled in my general WP settings,isn't that enough?

    I am very confused.

    Posted: 9 months ago #

RSS feed for this topic

Reply »

You must log in to post.

  • Rating

    12345
    6 Votes
  • Status

    This idea is under consideration