WordPress.org

Ready to get started?Download WordPress

Ideas

don't insert p and br around images when editing post in html mode

  1. Jason Lewis
    Member

    12345

    WordPress automatically adds <p> </p> around images in a post, even when the user is editing in html mode.

    I understand that wp automaticaly adds new lines for the user to make things look nice but I think if the user is editing in html mode, WP should render exactly what the user entered. It makes it very confusing trying to layout a page only to find WP is adding extra html.

    You can solve this by using a plugin like "PS Disable Auto Formatting" but I think it would be nice if there was a way to control this in wordpress by default

    Posted: 2 years ago #
  2. wpwalker
    Member

    Yes please! I have been researching this general problem today, after several years of being pretty irked by WordPress changing my so-beautiful and thought-out html code.

    Found a 21-page discussion from *6 years ago*! at https://wordpress.org/ideas/topic/trust-me-when-i-edit-html

    yes please :)

    Posted: 1 year ago #

RSS feed for this topic

Reply

You must log in to post.

  • Rating

    12345
    3 Votes
  • Status

    This is plugin territory